Cocoapods 1.0.0にアップデートした時の対応

ターゲットの指定が必須

0.39.0の記述

platform :ios, "8.0"
use_frameworks!

pod 'Google/Analytics'
pod 'AFNetworking'
pod 'SSKeychain'
pod 'SVProgressHUD'


1.0.0の記述

platform :ios, "8.0"
use_frameworks!

target "Sample" do
  pod 'Google/Analytics'
  pod 'AFNetworking'
  pod 'SSKeychain'
  pod 'SVProgressHUD'
end



Acknowledgementsファイルのパスの変更

0.39.0
FileUtils.cp_r('Pods/Target Support Files/Pods-Sample/Pods-Sample-acknowledgements.plist', 'Sample/Settings.bundle/Acknowledgements.plist', :remove_destination => true)

1.0.0
FileUtils.cp_r('Pods/Target Support Files/Pods/Pods-acknowledgements.plist', 'Sample/Settings.bundle/Acknowledgements.plist', :remove_destination => true)

DataStoreの辛いところ

# DataStoreの限界 FacebookやインスタグラムのようなSNSで、投稿、公開範囲、お気に入りなどの機能をDataStoreで実現しようとするとどうしても辛くなる。 ## DataStoreで実現可能? - users - id - feeds - i...